#202 new
BPere

dragdrop zIndex auto becomes 0

Reported by BPere | May 15th, 2009 @ 02:18 PM

the css value of the zIndex proeprty of our element is "auto"
when starting the drag to zIndex is set to 1000.
After dragging the zIndex is set to 0. (instead of auto).

the control that we drag contains some kind of a picker. That picker has also a zIndex with value 200.
When the dragging is finished the zIndex of the picker is ignored are are layout look like crap.
When I modified the line in dragdrop.js:436 to

this.element.style.zIndex = this.originalZ || "auto";

then it works perfect.

attached a example before after after the modification.

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

script.aculo.us is an open-source JavaScript framework for visual effects and interface behaviours.
<br/><b>Source available from github</b>
The Git repository resides at:
<a href="http://github.com/madrobby/scriptaculous">http://github.com/madrobby/scriptaculous</a>
<br/>Check out the current development trunk with:
<code>git clone git://github.com/madrobby/scriptaculous.git</code>
<br/>As <b>script.aculo.us 1.xx is feature-frozen</b>, this development trunk is for <b>bugfixes only</b>.
<br/>New development should happen only for
<b>script.aculo.us 2</b>.
<br/><b>Creating a bug report</b>
When creating a bug report, be sure to include as much relevant information as possible. Post a an example that shows off the problem. Preferably, <b>alter the unit tests</b> and show through either changed or added tests how the expected behavior is not occuring.

People watching this ticket

Attachments

Pages