#174 new
nbc

Draggable z-index doesn't work on IE

Reported by nbc | February 20th, 2009 @ 05:56 PM

It seems that z-index doesn't work with ie (i try with 6, 7 and 8), the draggable element stay under elements declared after in the html page (sorry for my lacs in english). juste send me a mail if you need more informations

Comments and changes to this ticket

  • nbc

    nbc February 23rd, 2009 @ 01:12 PM

    I think I've found the problem, it seems that the object 1 stay under the object 2 because his parent (about object 1) have a z-index less than my object 2 so the z-index of object 1 is ignored.

    (in my case it's easy to solve because there is juste 2 levels of hierarchy but in general it means that we should care about the z-index of all level of hierarchy for the object to drag against all other's object on the html sheet, it's not great damn to IE)

    please look to this case and tel me if I'm right.

    real thank you for your so good work !

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

script.aculo.us is an open-source JavaScript framework for visual effects and interface behaviours.
<br/><b>Source available from github</b>
The Git repository resides at:
<a href="http://github.com/madrobby/scriptaculous">http://github.com/madrobby/scriptaculous</a>
<br/>Check out the current development trunk with:
<code>git clone git://github.com/madrobby/scriptaculous.git</code>
<br/>As <b>script.aculo.us 1.xx is feature-frozen</b>, this development trunk is for <b>bugfixes only</b>.
<br/>New development should happen only for
<b>script.aculo.us 2</b>.
<br/><b>Creating a bug report</b>
When creating a bug report, be sure to include as much relevant information as possible. Post a an example that shows off the problem. Preferably, <b>alter the unit tests</b> and show through either changed or added tests how the expected behavior is not occuring.

People watching this ticket

Attachments

Pages