#170 new
Tobin

Builder adds multiple tbodies in IE

Reported by Tobin | February 11th, 2009 @ 09:46 PM

Using Scriptaculous Builder to build and add a table to the DOM, I noticed that in IE7, there are 2 <tbody> elements being added to the <table> element. The first <tbody> is empty, the second contains the correct html. Using just native commands (no Scriptaculous), I correctly only get one <tbody>.

I've attached a sample HTML file illustrating the problem.

I currently only have access to IE7, so I don't know what happens in IE6 or IE8. It works correctly in Firefox 3 and Safari 3.

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

script.aculo.us is an open-source JavaScript framework for visual effects and interface behaviours.
<br/><b>Source available from github</b>
The Git repository resides at:
<a href="http://github.com/madrobby/scriptaculous">http://github.com/madrobby/scriptaculous</a>
<br/>Check out the current development trunk with:
<code>git clone git://github.com/madrobby/scriptaculous.git</code>
<br/>As <b>script.aculo.us 1.xx is feature-frozen</b>, this development trunk is for <b>bugfixes only</b>.
<br/>New development should happen only for
<b>script.aculo.us 2</b>.
<br/><b>Creating a bug report</b>
When creating a bug report, be sure to include as much relevant information as possible. Post a an example that shows off the problem. Preferably, <b>alter the unit tests</b> and show through either changed or added tests how the expected behavior is not occuring.

People watching this ticket

Attachments

Pages