#631 ✓fixed_in_master_branch
michael (at mdaines)

iframeGetAttributeThrowsError check leaves strange "ghost" IFRAME in Safari

Reported by michael (at mdaines) | March 31st, 2009 @ 03:03 AM | in 1.6.1

Using the master branch and Safari (3.2.1 and the WebKit nightly), the "iframeGetAttributeThrowsError" check (in src/dom/dom.js) appears to leave a strange "ghost" entry in the Activity window and gives the page the appearance of a partially-loaded document (something like "Loading [path], completed 2 of 3 items" shows up in the status bar indefinitely).

(To figure out what was going on, I used the debugger in the WebKit nightly and stepped through until the behaviour appeared.)

As far as I can tell, this happens any time Prototype is included in any HTML document, even if nothing is used, since it's part of Prototype's normal loading process. I've attached a simple example. I guess this is mostly cosmetic, but it's still a little annoying.

I assume this can be avoided by doing something about the iframe after the iframeGetAttributeThrowsError check is done with it.

Comments and changes to this ticket

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

The Prototype JavaScript library.

Shared Ticket Bins

Attachments

Referenced by

Pages