#495 ✓invalid
Pavel Sokolov

cursor is hidden, when re-enabling form in 1.6.0.3

Reported by Pavel Sokolov | December 16th, 2008 @ 08:09 PM | in 1.6.1

Hello! I use Firefox 3.0.4 and prototype 1.6.0.3 and i found this problem:

1.I disabling form elements 2.I enabling form elements

after this focus is still on element, but cursor was hidden!

in 1.6.0.2 it works fine.

thank you.

Comments and changes to this ticket

  • Tobie Langel

    Tobie Langel January 27th, 2009 @ 06:25 PM

    • Tag changed from 1.6.0.3 to form
    • State changed from “new” to “bug”
    • Assigned user set to “Tobie Langel”

    @@@FormElement#disable@@@ originally also called @@@FormElement#blur@@@.

    This is seemingly no longer the case. We'll need to investigate why.

  • Tobie Langel

    Tobie Langel January 27th, 2009 @ 06:26 PM

    • Milestone set to 1.6.1
  • Juriy Zaytsev

    Juriy Zaytsev February 23rd, 2009 @ 01:08 AM

    • State changed from “bug” to “invalid”

    I don't see what's wrong with this behavior.

    Using native methods has the same effect in FF3.0.x. The following snippet disables an element while leaving a focus outline.

    
    el.focus();
    el.disabled = true;
    

    We also can't focus element back since we don't know which element was focused in the first place.

    Closing as invalid. Please reopen if I missed something.

  • Tobie Langel

    Tobie Langel July 24th, 2009 @ 02:01 AM

    • Tag changed from form to section:dom

    [not-tagged:"form" tagged:"section:dom" bulk edit command]

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

The Prototype JavaScript library.

Shared Ticket Bins

Attachments

Pages