#16 new
wout

Element#appear doesn't work properly in webkit desktop browsers

Reported by wout | July 13th, 2010 @ 03:07 PM

Hi,

I'm working on a slideshow app and i'm cross-fading images when they are loaded (img.complete).
Fading is working but appear is applied instantly (like Element#show).

This is a workaround:

nextSlide.
  setOpacity(0).
  show().
  appear();

It seems to be something related to webkit, because this happens in both Safari 5 and Google Chrome (latest).
MobileSafari (4), FireFox (3.6) and Opera (10.x) do work fine.

I guess it has something to do with the webkit css transitions?

Comments and changes to this ticket

  • Terry Morgan

    Terry Morgan September 28th, 2010 @ 03:52 PM

    • Tag set to 24, hour, hazwoper, lta, hrefhttp:www.replicamen.comgtreplica, watchesltagt, training, course, hrefhttp:www.replicamen.comgtfake, now, offers, hrefhttp:www.replicamen.comgtwatchesltagt, you, attractive, bulk, hrefhttp:www.replicamen.comrolex-wa

    I've experiencing this too in both alpha 6 and beta 1. A short term workaround is to disable the webkit transitions by setting the 'engine' parameter to 'javascript', like so:

    element.appear({ duration: 1, engine: 'javascript' });

  • capripot

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

http://github.com/madrobby/scripty2

People watching this ticket

Pages